Appointlet - Google Calendar Sync Issues – Incident details

Google Calendar Sync Issues

Resolved
Partial outage 25 %
Started 11 months agoLasted about 1 hour

Affected

Scheduling Pages

Partial outage from 8:05 PM to 9:10 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are currently experiencing intermittent issues with our Google Calendar sync functionality. This is due to an ongoing upstream incident with Google Cloud. We are actively monitoring the situation and will provide updates as they become available.

    You can follow the status of the incident directly from Google here: Google Cloud Status

    Thank you for your patience and understanding.