Elevated Office 365 Latency (again)

Resolved
Degraded performance
Started 11 months ago Lasted about 4 hours

Affected

Scheduling Pages
Updates
  • Resolved
    Resolved

    We're no longer seeing any timeouts and have received notice from Microsoft that a fix has been implemented, so we're going to close this issue.

  • Monitoring
    Monitoring

    We're seeing more timeout issues with the Office 365 APIs, so some scheduling pages that use Office 365 might be loading slowly or not at all.

    We apologize for the inconvenience and we'll update you when we hear more from Microsoft.