Resolved
Meeting emails are delayed

Started
June 22, 2022 at 12:39 AM
Status
Resolved after about 4 hours
Affected
App

Impact

Degraded performance
  • Resolved
    June 22, 2022 at 4:37 AM

    We're no longer seeing any delayed emails, so we're closing this issue.

  • Monitoring
    June 22, 2022 at 2:42 AM

    We've identified the issue and have deployed a fix. The backlog of delayed emails is clearing and the issue should be completely resolved shortly.

  • Investigating
    June 22, 2022 at 12:39 AM

    We're currently investigating reports that meeting confirmation and reminder emails are delayed.