Elevated Office 365 Latency

Resolved
Degraded performance
Started 11 months ago Lasted about 1 hour

Affected

Scheduling Pages
Updates
  • Resolved
    Resolved

    Microsoft has confirmed that the issue is resolved on their end, so we're closing this ticket.

    Thank you for your patience.

  • Monitoring
    Update

    We're no longer seeing issues loading scheduling pages that use Office 365, however we're going to leave this issue active until we've heard confirmation from Microsoft that the issue is resolved on their end.

  • Monitoring
    Monitoring

    We're seeing elevated latency to the Office 365 API, which may be impacting the speed at which some scheduling pages load.

    We're in contact with our rep at Microsoft and they are aware of the issue and are investigating. We'll update here when we know more.