Emails are not being delivered

Resolved
Partial outage
Started almost 2 years ago Lasted about 3 hours

Affected

Website
Updates
  • Resolved
    Resolved

    We've heard from our upstream provider that all emails are now being sent promptly, so we're marking this issue as resolved.

  • Monitoring
    Monitoring

    We've just heard from our email sender that new emails are going out immediately, and they're working on clearing the backlog of previously queued emails.

    We're continuing to monitor and will update you when the issue is resolved.

  • Identified
    Update

    We're continuing to monitor the situation. The actual cause is related to an Amazon datacenter losing power, which is causing issues across the greater internet, including some of our upstream providers.

    To clarify, our services are otherwise functioning: new meetings can be scheduled, but emails are delayed.

  • Identified
    Identified

    Our upstream provider has identified the issue and is working rapidly to resolve. We will continue to update you as we hear more.

  • Investigating
    Investigating

    Our upstream email provider is having issues and currently meeting status emails are not being delivered. They have indicated that when the issue is resolved all previously queued emails will be sent.

    We will update this ticket when we hear more.