Outbound email notifications may be delayed

Resolved
Operational
Started about 2 years ago Lasted 29 minutes

Affected

Mobile App
Updates
  • Resolved
    Resolved

    Our upstream provider has indicated that the issue is resolved.

  • Investigating
    Investigating

    Our upstream email provider is experiencing some delays sending emails, so far we're not seeing any impact, but we will continue to monitor.