Appointlet - Possible Email Sending Delays – Incident details

Possible Email Sending Delays

Resolved
Degraded performance
Started about 1 month agoLasted about 2 hours

Affected

Emails

Degraded performance from 8:34 PM to 10:18 PM

Updates
  • Resolved
    Resolved

    This issue has been resolved.

  • Monitoring
    Monitoring

    Our upstream provider is reporting that the issue has been resolved. We will continue to monitor.

  • Identified
    Identified

    Our upstream email provider is having some technical difficulties. Emails may be delayed at this time.